Как сделать в Excel кроссворд
Papa-jobs.ru

Ремонт телефонов

Как сделать в Excel кроссворд

Создание кроссворда в программе Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Как видим, границы, очерчивающие наш кроссворд, установлены.

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Читать еще:  Русификация «Telegram» на Android

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Как сделать в Excel кроссворд

Создание макета кроссворда.

· Запустите электронную таблицу MS Excel : Пуск – Программы – Microsoft Office – Microsoft Excel .

· Перенесите макет кроссворда (столбцы и строки) на рабочий лист программы, выделив ячейки для слов с помощью инструмента Таблицы и границы – вкладка Главная. Оставьте сверху одну или две пустые строки для названия кроссворда.

· Заполните и пронумеруйте слова в кроссворде. В каждую ячейку должна вводиться одна буква. Установите желаемый размер и тип шрифта.

· Настройте высоту и ширину ячеек: выделите столбцы, подведите курсор к границе столбца в области строки с буквами-именами столбцов. Нажав левую кнопку мыши, перетащите границу одного из столбцов (ширина всех выделенных столбцов станет одинаковой).

Проверка правильности решения кроссворда.

Чтобы проверить, правильно ли ученик заполнил кроссворд, нужно сравнить каждое введенное слово с образцом – правильным ответом. Иначе говоря, для каждого слова мы будем сравнивать значения двух ячеек – с введенным словом и правильным ответом, и если они равны, помечать это слово как «верно».

Запишем на свободном месте листа Excel правильные ответы (потом эта информация будет скрыта).

Но если правильный ответ представляет из себя целое слово, записанное в одной ячейке, то ответ ученика – это совокупность нескольких ячеек, в каждой из которых записано по одной букве. Поэтому мы должны ответ ученика преобразовать так, чтобы его можно было сравнить с правильным ответом, то есть соединить отдельные буквы из разных ячеек в целое слово, записанное в одной ячейке. Для этого будем использовать функцию для текстовых величин СЦЕПИТЬ.

· Выделите ячейку, в которой будет записан преобразованный ответ ученика (в моем примере это ячейка, в которой записаны ответы студента ).

· В данной ячейке введите формулу (наберите с клавиатуры или воспользуйтесь командой Вставить функцию на вкладке Формулы): =СЦЕПИТЬ ( ячейка с первой буквой слова; ячейка со второй буквой слова ; ячейка с третьей буквой слова ; т.д.; ).

Теперь можно сравнить правильный ответ с ответом ученика. Для этого будем использовать функцию ЕСЛИ: если слова совпадут, напишем напротив ответа «1», если нет «0». Мы используем числовые значения, а не слова «верно» – «неверно», потому что в дальнейшем проще будет подсчитать количество правильно угаданных слов.

Введите в ячейку : =ЕСЛИ(ячейка с правильным ответом=ячейке с ответом студента;1;0).

С помощью маркера автозаполнения копируем формулу по столбцу на весь необходимый диапазон.

· Ниже напишите «Количество правильных ответов» и введите в соседнюю ячейку формулу: = СУММ(первая ячейка с правильностью ответов: последняя ячейка с правильностью ответов )

Скройте все строки с ответами ученика, правильными ответами и количеством угаданных слов.

Пусть в процессе разгадывания кроссворда на экране высвечивается комментарий «Отлично!», «Хорошо!», «Пока на «троечку»», «Пока не угадано ни одного слова». Для этого введите в ячейку формулу:

=ЕСЛИ(ячейка с количеством отгаданных слов=0;”Пока не угадано ни одного слова”;ЕСЛИ( ячейка с количеством отгаданных слов ячейка с количеством отгаданных слов

Создадим кнопку для очистки ячеек кроссворда с использованием макроса.

Нажмите кнопку « Office » , затем «Параметры Excel », выберите в списке с левой стороны открывшегося окна «Настройка», затем из списка вкладок выберите «Разработчик».

В списке команд найдите «Элементы управления» и нажмите кнопку «Добавить», затем кнопку «ОК». Кнопка «Элементы управления» будет добавлена на панель быстрого доступа.

На панели быстрого доступа нажмите кнопку «Элементы управления», «Вставить», «Элементы управления формы», «Кнопка».

Нарисуйте кнопку. Автоматически откроется окно «Назначить макрос объекту». Нажмите на кнопку «Записать», затем «ОК».

Выделите последовательно все клетки кроссворда и удалите из них буквы.

На вкладке Вид выберите Макросы- Остановить запись.

Теперь щелчок левой кнопкой мыши будет запускать макрос, а щелчок правой кнопкой – вызывать контекстное меню.

Чтобы изменить название кнопки, выберите в контекстном меню «Изменить текст» и введите свое название (Очистить кроссворд).

Для правильного функционирования макроса не забудьте перед работой уровень безопасности макроса выбрать Низкий: кнопка Office – Параметры Excel – Центр управления безопасности – Параметры центра – управление безопасностью – Параметры макросов – Включить макросы.

Проверьте работу кроссворда (выставление оценки и кнопку очистки кроссворда).

Создание кроссворда в Microsoft Excel

Автор: Кириллов Владислав Александрович

Очень часто в учебном процессе требуется проверить знания учащихся «не стандартным» способом. И один из этих способов – кроссворд. Далее возникает вопрос реализации этой задачи:

  1. Нахождение вопросов и ответов для кроссворда
  2. Публикация в электронном виде

При выполнении второго пункта рассматриваем основное программное обеспечение, в котором можно выполнить данную задачу. Одна из распространенных программ в которой это выполнимо – Microsoft Excel. Так как практически на любом компьютере присутствует пакет Microsoft Office.

Итак, для того чтобы создать кроссворд в Microsoft Excel, создаем файл и переименовываем его. Открываем и переименовываем листы:

  • Титульный лист;
  • Кроссворд;
  • Обработка результатов.

Переходим на лист «Кроссворд» и выделяем все ячейки, чтобы выставить размер всех ячеек. Выбираем «Формат => Ширина столбца…» и устанавливаем размер 3.

Далее «Формат => Высота строки…» устанавливаем высоту строки равную 20 пунктам.

Теперь мы должны заполнить ответы кроссворда так как они будут расположены в кроссворде и рядом пишем пояснение (вопрос).

Что бы расставить номера вопросов есть несколько вариантов:

  • Поставить цифры рядом со словом
  • Поставить примечания на первые буквы слова

Второй вариант мне предпочтителен. Чтобы это сделать нужно:

  1. Выделить ячейку с первой буквой слова
  2. Нажать «Рецензирование => Создать примечание»
  3. Переименовываем в нужный номер вопроса

Далее оформим границы кроссворда.

Для этого выделяем первое слово и зажав кнопку «Ctrl» выделяем все остальные ячейки кроссворда.

Нажимаем «Главная => Формат => Формат ячеек» и настраиваем внешний вид ячеек, самое важное это выбрать «Границы => Внутренние и внешние»

Теперь можно подумать о внешнем виде кроссворда, а именно:

  • Цвет и заливка ячеек;
  • Вставка картинок, как дополнение;
  • Вставка подложки (фон листа).

Первое решается через «Формат ячеек», второе через «Вставка => Рисунки», а третье

Во вкладке «Разметка страницы» нажимаем кнопку «Подложка» и выбираем изображение с компьютера или из коллекции Microsoft.

Убираем сетку, для этого выберем «Вид => Показать или скрыть» и снимем галочку с «Сетка» (Microsoft Office 2007), в Microsoft Office 2013 «Вид» и снимаем галочку с «Сетка».

Читать еще:  Что делать, если ОП не обнаруживается системой

Оформление листа «Кроссворд» на этом окончено, переходим к листу «Обработка результатов».

На этом листе нужно будет создать некоторую таблицу:

В столбце «А» и «В» вводим номера и ответы на вопросы

Для заполнения столбца «С», нам нужно соединить буквы слова, находящиеся в разных ячейках на странице «Кроссворд» , в одной ячейке. Для этого в ячейке «С2» вставляем функцию «=СЦЕПИТЬ()». Формулу можно прописать вручную или найти в «Функции => Текстовые => СЦЕПИТЬ». Выбираем все ячейки ответа по порядку, зажав кнопку «CTRL» и нажимаем «Enter».

И все тоже выполняем для всех ответов на вопросы.

Далее, заполняем столбец «D», в нем мы должны проверить, соответствуют ли значения столбца «В» значениям столбца «С». Для этого воспользуемся логической функцией «ЕСЛИ». Если значения в ячейках совпадают, то начисляется 1 балл, иначе 0. И так для всех ответов, что бы не вводить везде можно воспользоваться автозаполнением, а лишние выделенные ячейки удалить.

На следующем шаге заполняем «Титульный лист». Само оформление зависит от Вас, но самое главное это добавить ячейки с выводом результата. Вводим текст: «Верное количество ответов» и напротив него вводим формулу «СУММ()». В ней указываем данные на странице результатов, выделяем все ячейки с баллами.

Второй обязательной строчкой будет: «Ваша оценка». Для нее будем использовать функцию «ЕСЛИ» несколько раз. Сначала вводим

Нажимаем «Enter» и вместо «0» в функции опять вставляем «ЕСЛИ», вписываем условие для получения оценки «4»:

Тоже самое для оценки «3», но вместо «0» пишем оценку «2». Так же вместо оценки можно вставлять слова «Умница», «Хорошо», «Удовлетворительно», «Попробуй в следующий раз».

Осталось скрыть лист «Обработка результатов». Для этого нужно нажать правой кнопкой на лист и выбрать «Скрыть».

Или же воспользоваться кнопкой «Формат => Скрыть ли отобразить»

Вместо того чтобы создавать 3 листа все можно было разместить на одном листе. Все что не должен видеть ученик можно так же скрыть. Выделить текст, а потом через «Формат => Скрыть ли отобразить» нажать «Скрыть строки».

Если есть необходимость, то можно защитить книгу, что бы никто кроме Вас не мог отобразить скрытые строки или поменять структуру кроссворда. Нажимаем «Рецензирование => Защитить книгу => Структуру», вводим пароль и подтверждаем.

Выделяем заполненный кроссворд и удаляем ответы.

Видеоурок по созданию кроссворда в Excel

Желаю удачного создания кроссвордов!

Как сделать в Excel кроссворд

Программы из пакета Mircosoft Office предназначены для работы с документами в самых разных их проявлениях. За время, прошедшее с момента запуска пакета и до сегодняшнего дня, каждая из этих программ обросла множеством полезных и важных функций, так что пользователь может выполнить практически любую операцию всего парой нажатий мышью.

Специальные функции позволяют автоматизировать процесс работы

Однако есть вещи, которые сделать не так просто. Например, в Excel — программе для работы с таблицами — компания встроила механизм функций, которые может использовать пользователь. С их помощью можно обрабатывать самые разные данные. Но автору придётся лично выстраивать модель взаимодействия, вводя формулы и указывая диапазоны данных.

Нужно учитывать также то, что перед пользователем встают иногда весьма нетривиальные задачи — как, например, создать кроссворд в Excel. Понятно, что в самой программе такой функции нет, так что нужно будет кое-что всё же выполнить вручную.

Первый этап

Перед тем как начать создание кроссворда с проверкой в Excel, вам нужно определиться со списком вопросов и ответов. Мы рекомендуем завести для этого отдельный файл и сразу вписать строчки так, как они должны выглядеть в результате работы. После этого откройте программу; необходимо создать новую книгу, если она не создаётся автоматически. Это нужно потому, что наш способ будет использовать одновременно два рабочих листа, поэтому целесообразно выделить их в отдельный файл. Итак, переименуем «Лист 1» так, как вам удобно. По сути, его имя может быть произвольным, главное, чтобы вы его потом не меняли. На этом листе с помощью границ нужно нарисовать контур будущего кроссворда.

Выделяем ячейки по горизонтали или вертикали, находим в ленте настроек вкладку «Разметка страницы» и нажимаем на кнопку «Границы». Если вам недостаточно появившихся на экране вариантов, смело выбирайте свои в одноимённом пункте. Теперь на листе у нас появился контур одного из слов. Нужно повторить это столько раз, сколько вопросов вы хотите включить в своё творение. Не забывайте ставить числа в первые ячейки, чтобы потом не пришлось вспоминать, какое именно слово должно быть сюда вписано.

Если вам не нужно делать кроссворд с проверкой, Excel можно закрывать, так как на этом собственно рисование заканчивается. Вы можете, например, вставить его в Ворд или просто распечатать, чтобы получить на листе бумаги нарисованную сетку с пересечениями в нужных местах. При должной сноровке вы можете даже «Заливкой ячейки» закрасить некоторые из них чёрным цветом, чтобы получить стилизацию под напечатанный в газете кроссворд. Однако это самый простой вариант.

Второй этап

Если проверять впечатанные пользователем слова всё же нужно, придётся немного схитрить. Дело в том, что фоновую проверку слов, чтобы пользователь её не видел, можно осуществить разве что с помощью макросов. Но если воспользоваться встроенными средствами Excel, то можно добиться похожего результата. Для этого скопируйте лист с кроссвордом, щёлкнув по нему правой кнопкой мыши. Полученный лист переименуйте (имя тоже может быть произвольным). В клетки кроссворда, сделанного на втором листе Excel, впишите ответы — это нужно будет для проверки правильности введённых пользователем букв.

Теперь рядом с кроссвордом сделайте небольшую табличку из двух столбцов. В первом будет указан номер вопроса, во втором — результат отгадки. Используем интуитивно понятную систему: 1 — если ответ правильный, и 0 — во всех остальных случаях. Наш кроссворд не будет учитывать сделанные пользователем опечатки, так что они тоже будут туда попадать.

Теперь нужно в ячейки второго столбца нашей проверочной таблицы добавить формулу. Её суть в том, чтобы сравнивать диапазон ячеек на первом листе с аналогичным диапазоном на втором. Диапазоны — слова в кроссворде. Если они совпадают, то в столбец на этой строке заносится единица, если нет — ставится ноль. Провести такую проверку можно с помощью оператора сравнения, формула в общем виде будет выглядеть примерно так: =ЕСЛИ((Кроссворд.D1=Ответ.D1) И (Кроссворд.D2=Ответ.D2) И … ) ТО 1 ИНАЧЕ 0.

Читать еще:  Что делать, если отключается Wi-Fi на ноутбуке

Как видите, она не очень-то сложная, правда, выстраивать диапазон ячеек вам нужно очень внимательно. Кстати, именно для того, чтобы сделать кроссворд с проверкой в Excel, мы копировали заполненный кроссворд на второй лист. Это гарантирует, что ячейки на проверочном листе находятся по тем же адресам, что и на основном.

Последние штрихи: на листе с кроссвордом можно сделать счётчик количества правильно отгаданных слов, чтобы пользователь ориентировался в нём. Для этого просто суммируем данные из второго столбца проверочной таблицы. Ну, и осталось только скрыть этот лист, щёлкнув по нему правой кнопкой мыши и выбрав одноимённый параметр.

Заключение

Решение этой, на первый взгляд нетривиальной задачи на поверку оказывается не таким уж сложным. Используя гибкость встроенных функций Excel, вы можете создавать кроссворды как с проверкой, так и без неё, причём делать это так, как считаете нужным. Ведь мы описали только один из возможных способов.

Делаем кроссворд в Excel

Составление кроссвордов в программе Microsoft Excel более желательно, нежели проделывание подобной процедуры в Word. Дело в том, что функционал Excel позволяет создать этот сканворд быстрее, плюс, имеется возможность создать проверку для кроссворда. В Word такой возможности.

Ранее мы уже разбирали, как создать кроссворд в MS Word. Рекомендуем ознакомиться с этой статьёй для лучшего понимания.

Как создать кроссворд в Excel

Для начала лучше обдумать структуру кроссворда заранее и начертить её где-нибудь на бумаге. Можно найти в сети уже готовый сканворд и скопировать его структуру. Когда всё будет готово переходите в интерфейс Excel.

Этап 1: Создаём сканворд

Задать саму структуру будущего кроссворда можно, если выполнить следующие действия:

  1. Запустите Excel. Как видите, ячейки здесь прямоугольные. Они не подходят для создания кроссворда, поэтому придётся поменять их форму. Выделите вся ячейки на листе, воспользовавшись сочетанием клавиш Ctrl+A.
  2. Нажмите правой кнопкой мыши по выделению. Из контекстного меню выберите вариант «Высота строки».

Откроется окошко с настройками высоты строки. Здесь задайте любое удобное вам значение, но не сильно большое. Например, мы установим высоту в 20 единиц. Жмите «Ок» для применения изменений.

  • Теперь кликните правой кнопкой мыши по названию любого столбца. Из контекстного меню выберите вариант «Ширина столбца».
  • Установите здесь значение 3 и нажмите «Ок».

  • Определитесь с размером кроссворда в вертикальном и горизонтальном положении. Сделайте выделение области в соответствии с тем, сколько клеток вы запланировали в сканворде.
  • Теперь в верхней строке, в блоке инструментов «Шрифт», кликните по кнопке «Граница». Из контекстного меню выберите «Все границы».

    Границы, которые очерчивают сканворд успешно установлены. Теперь выделите те его части, которые не нужны в кроссворде, то есть куда ничего не будет вписываться. В блоке инструментов «Редактирование» нажмите на кнопку в виде ластика. Таким образом вы удалите выделение у тех участков, где оно не требуется.

  • Дополнительно можно выделить каким-нибудь акцентным цветом главную полосу кроссворда. Выделите эту полосу и измените у неё цвет с помощью инструмента заливки, что расположен в блоке «Шрифт».
  • Основная структура кроссворда готова, теперь осталось только пронумеровать строки и столбцы, а также прописать вопросы в отдельном блоке.

    1. Выделите ячейку около нужной строки/столбца. Поставьте в ней номер данной ячейки. Если цифра номера слишком большая, то вы можете уменьшить её, выбрав соответствующий размер в блоке инструментов «Шрифт». Также можно настроить выравнивание цифры в соответствующем блоке.
    2. Теперь нужно выделить область, в которую будут записаны вопросы. Её размер может быть произвольным, главное, чтобы все данные поместились в указанной области.
    3. В выделенной области нужно убрать разбиение на ячейки. Нажмите по ней правой кнопкой мыши и выберите из контекстного меню «Объединить ячейки».

  • Вставьте туда заранее подготовленный текст или пропишите вопросы вручную.
  • Этап 2: Проверка правильности

    Вы можете также сделать проверку кроссворда в Excel. Правда, она будет доступна только для тех пользователей, которые разгадывают его в электронном виде. Для печати функция проверки недоступна.

    Делается проверка готового кроссворда следующим образом:

    1. Создайте дополнительный лист для таблицы. Здесь запишите ответы в формате таблицы. Разделите её на столбцы:
      • «Ответы». Сюда вписываются сами ответы на вопросы;
      • «Введено». В этом столбце вписываются данные, которые пользователь ввёл;
      • «Совпадения». Здесь Excel будет сверять данные введённые пользователем с ответами;
      • Ещё внизу можно создать блок «Итого», где будет подсчитана сумма верных ответов.

  • Переключитесь на первую ячейку столбца «Введено». Здесь нужно задать специальную функцию. Нажмите на кнопку в виде буквы «f» около строки ввода данных.
  • Будет открыт мастер создания функций. В нём найдите функцию, которая называется «Сцепить». Выберите её и нажмите «Ок», чтобы она применилась.

  • Откроется окошко задания аргументов для функции. Здесь нужно нажать на кнопку в виде таблички, что расположена около строки ввода аргумента.
  • Переключитесь на первый лист и выберите все ячейки той строки, которая соответствуют нужному вопросу.
  • Проделайте аналогичную операцию с другими ответами.

    Теперь переключитесь на первую ячейку совпадений. Сюда нужно задать функцию «Если». Она будет иметь следующий вид: «=ЕСЛИ(номер_ячейки_ответа=номер_ячейки_введено;1;0)». Вот так она выглядит у нас: «=ЕСЛИ(A4=B4;1;0)». То есть, если ответ пользователя совпадает с записанным в таблице ответом, то в «Совпадение» пишется один балл. В противном случае ставится 0.

  • Переключитесь к строке «Итого». Здесь нужно прописать функцию «СУММ», чтобы суммировать полученные баллы. В скобках этой функции проставьте номера ячеек, которые требуется просуммировать.
  • Осталось только вписать завершающую функцию на первом листе с кроссвордом, которая будет выдавать, правильно ли он решён или нет.

    1. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу. Именно от этого числа нужно будет составлять дальнейшую формулу.
    2. Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

    Теперь, если пользователь ответил на один или несколько вопросов неверно, то система предложит ему подумать ещё. В противном случае Excel оповестит человека о том, что он решил кроссворд правильно.

    Ссылка на основную публикацию
    Adblock
    detector